use strict;
my $str = '918364
S122 - 19280
53742584
M415
211.2233.22
M415R
G15690
51168081
51168081
93453935
79676246
13600235
M3900301
230138859
71133713
4249790
207570
207570
934259
3296851
20921057
00709199
90549079
61001358
DAWN
10140332
2R5-5611
1000853235
17H383573
164778157
287353
93388870';
my $regex = qr/^([SGMRHDAWN0-9]{1,11})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}