$re = '/(.*)(-)([02468](?!.*\d))(.*)/';
$str = '99999F01P175N_KBA001.PDF_1-2.pdf
99999F01P175N_KBA001.PDF_1-102.pdf
99999F01P175N_KBA001.PDF_1-202.pdf
99999F01P175N_KBA001.PDF_1-205.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);