import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(-)([02468](?!.*\\d))(.*)";
final String string = "99999F01P175N_KBA001.PDF_1-2.pdf\n"
+ "99999F01P175N_KBA001.PDF_1-102.pdf\n"
+ "99999F01P175N_KBA001.PDF_1-202.pdf\n"
+ "99999F01P175N_KBA001.PDF_1-205.pdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}