#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*)(-)([02468](?!.*\d))(.*)"
Local $sString = "99999F01P175N_KBA001.PDF_1-2.pdf" & @CRLF & _
"99999F01P175N_KBA001.PDF_1-102.pdf" & @CRLF & _
"99999F01P175N_KBA001.PDF_1-202.pdf" & @CRLF & _
"99999F01P175N_KBA001.PDF_1-205.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")