use strict;
my $str = '99999F01P175N_KBA001.PDF_1-2.pdf
99999F01P175N_KBA001.PDF_1-102.pdf
99999F01P175N_KBA001.PDF_1-202.pdf
99999F01P175N_KBA001.PDF_1-205.pdf';
my $regex = qr/(.*)(-)([02468](?!.*\d))(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}