re = /\/pojisteni\/pojisteni-majetku\/([a-z]*-*)*pojistovna.*/
str = '/pojisteni/pojisteni-majetku/csob-podnik-pojistovna/domex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end