$re = '/\/pojisteni\/pojisteni-majetku\/([a-z]*-*)*pojistovna.*/';
$str = '/pojisteni/pojisteni-majetku/csob-podnik-pojistovna/domex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);