using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/pojisteni\/pojisteni-majetku\/([a-z]*-*)*pojistovna.*";
string input = @"/pojisteni/pojisteni-majetku/csob-podnik-pojistovna/domex";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}