re = /(?<!\.)\b[0-9]+\b(?!\.)/m
str = '0.345, 54, 43, 3.14159, feing
reference:
https://stackoverflow.com/questions/28030520/python-regex-to-match-integers-but-not-floats'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end