using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\.)\b[0-9]+\b(?!\.)";
string input = @"0.345, 54, 43, 3.14159, feing
reference:
https://stackoverflow.com/questions/28030520/python-regex-to-match-integers-but-not-floats";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}