$re = '/(?<!\.)\b[0-9]+\b(?!\.)/m';
$str = '0.345, 54, 43, 3.14159, feing
reference:
https://stackoverflow.com/questions/28030520/python-regex-to-match-integers-but-not-floats';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);