#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\.)\b[0-9]+\b(?!\.)"
Local $sString = "0.345, 54, 43, 3.14159, feing" & @CRLF & _
"" & @CRLF & _
"reference:" & @CRLF & _
"https://stackoverflow.com/questions/28030520/python-regex-to-match-integers-but-not-floats"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")