// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:youtu\.?be(?:-nocookie)?(?:\.com)?(?:\/|watch\?v=|embed\/)+)([\w-]+)").unwrap();
let string = "www.youtube.com/watch?v=dQw4w9WgXcQ
http://www.youtube.com/watch?v=dQw4w9WgXcQ
https://youtu.be/dQw4w9WgXcQ
https://www.youtube.com/embed/dQw4w9WgXcQ
https://www.youtube-nocookie.com/embed/dQw4w9WgXcQ
https://youtu.be/dQw4w9WgXcQ?t=0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}