#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:youtu\.?be(?:-nocookie)?(?:\.com)?(?:\/|watch\?v=|embed\/)+)([\w-]+)"
Local $sString = "www.youtube.com/watch?v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ" & @CRLF & _
"https://youtu.be/dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/embed/dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube-nocookie.com/embed/dQw4w9WgXcQ" & @CRLF & _
"https://youtu.be/dQw4w9WgXcQ?t=0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")