package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:youtu\.?be(?:-nocookie)?(?:\.com)?(?:\/|watch\?v=|embed\/)+)([\w-]+)`)
var str = `www.youtube.com/watch?v=dQw4w9WgXcQ
http://www.youtube.com/watch?v=dQw4w9WgXcQ
https://youtu.be/dQw4w9WgXcQ
https://www.youtube.com/embed/dQw4w9WgXcQ
https://www.youtube-nocookie.com/embed/dQw4w9WgXcQ
https://youtu.be/dQw4w9WgXcQ?t=0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}