using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:youtu\.?be(?:-nocookie)?(?:\.com)?(?:\/|watch\?v=|embed\/)+)([\w-]+)";
string input = @"www.youtube.com/watch?v=dQw4w9WgXcQ
http://www.youtube.com/watch?v=dQw4w9WgXcQ
https://youtu.be/dQw4w9WgXcQ
https://www.youtube.com/embed/dQw4w9WgXcQ
https://www.youtube-nocookie.com/embed/dQw4w9WgXcQ
https://youtu.be/dQw4w9WgXcQ?t=0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}