re = /^.......$/m
str = 'test.txt
passwords.json
notes.doc
test2.txt
dont\'t forget!!!.txt
app.cfg
send.rtf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end