package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.......$`)
var str = `test.txt
passwords.json
notes.doc
test2.txt
dont't forget!!!.txt
app.cfg
send.rtf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}