#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.......$"
Local $sString = "test.txt" & @CRLF & _
"passwords.json" & @CRLF & _
"notes.doc" & @CRLF & _
"test2.txt" & @CRLF & _
"dont't forget!!!.txt" & @CRLF & _
"app.cfg" & @CRLF & _
"send.rtf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")