$re = '`^.......$`m';
$str = 'test.txt
passwords.json
notes.doc
test2.txt
dont\'t forget!!!.txt
app.cfg
send.rtf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);