re = /^(?=.*?[A-Z])[^0-9].{7,}$/m
str = 'fdhf
fdifhidhfdfd
hfhfhfhf
3343rAjrj
bd1A23nfdd
bd123nfDdd
abd16A3n
bad176A23n
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end