using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*?[A-Z])[^0-9].{7,}$";
string input = @"fdhf
fdifhidhfdfd
hfhfhfhf
3343rAjrj
bd1A23nfdd
bd123nfDdd
abd16A3n
bad176A23n
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}