$re = '/^(?=.*?[A-Z])[^0-9].{7,}$/m';
$str = 'fdhf
fdifhidhfdfd
hfhfhfhf
3343rAjrj
bd1A23nfdd
bd123nfDdd
abd16A3n
bad176A23n
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);