#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*?[A-Z])[^0-9].{7,}$"
Local $sString = "fdhf" & @CRLF & _
"fdifhidhfdfd" & @CRLF & _
"hfhfhfhf" & @CRLF & _
"3343rAjrj" & @CRLF & _
"bd1A23nfdd" & @CRLF & _
"bd123nfDdd" & @CRLF & _
"" & @CRLF & _
"abd16A3n" & @CRLF & _
"bad176A23n" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")