import Foundation
let pattern = #"(\S| )+\n(\S| )+\n(\S| )+\n((\S| )+|)NSW \d{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/////// 4 lines & 3rd line is suburb only
SCIENTIFIC MOTOR BODYWORKS LP
7-9 PERRY STREET
MATRAVILLE
NSW 2036
///////
au
Mascot Auto Repairs"cod**
155 Coward Street
Mascot NSW 2020
////////////////////////
Mascot Airport Service Station *cod*
Inside Car Wash
237 O'Riordan St
Mascot NSW 2020
////////////////////////maps
7/30-32 Beaconsfield Street
Alexandria NSW 2015
////////////////////////
Pedders Mascot
Unit 1
20 Ricketty Street
Mascot NSW 2020
/////////////////////
Pay Charge
Mr Bump Smash Repair
Unit 12/122 Station Rd
Seven Hills NSW 2147
////////////////////
Pay Charge
Mr Bump Smash Repair
Unit 12 122 Station Rd
Seven Hills NSW 2147
/////// suburb spelling error, character in street line
Woollahra Auto***cod***
120, Oxford St
Woolahra NSW 1350
/// name not complete
North Caringbah Smash Rep
47 Captain Cook Drive
Caringbah NSW 2229
/////
BM Pro Service Centre
Unit8/ 1a Pritchard Plac
Peakhurst NSW 2210
////
embassy smash repairs
unit 5d 23-25 windsor rd
northmead nsw 2152
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)