#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\S| )+\n(\S| )+\n(\S| )+\n((\S| )+|)NSW \d{4}"
Local $sString = "/////// 4 lines & 3rd line is suburb only" & @CRLF & _
"SCIENTIFIC MOTOR BODYWORKS LP" & @CRLF & _
"7-9 PERRY STREET" & @CRLF & _
"MATRAVILLE" & @CRLF & _
"NSW 2036" & @CRLF & _
"///////" & @CRLF & _
"au" & @CRLF & _
"Mascot Auto Repairs"cod**" & @CRLF & _
"155 Coward Street" & @CRLF & _
"Mascot NSW 2020" & @CRLF & _
"////////////////////////" & @CRLF & _
"Mascot Airport Service Station *cod*" & @CRLF & _
"Inside Car Wash" & @CRLF & _
"237 O'Riordan St" & @CRLF & _
"Mascot NSW 2020" & @CRLF & _
"////////////////////////maps" & @CRLF & _
"7/30-32 Beaconsfield Street" & @CRLF & _
"Alexandria NSW 2015" & @CRLF & _
"////////////////////////" & @CRLF & _
"Pedders Mascot" & @CRLF & _
"Unit 1" & @CRLF & _
"20 Ricketty Street" & @CRLF & _
"Mascot NSW 2020" & @CRLF & _
"/////////////////////" & @CRLF & _
"Pay Charge" & @CRLF & _
"Mr Bump Smash Repair" & @CRLF & _
"Unit 12/122 Station Rd" & @CRLF & _
"Seven Hills NSW 2147" & @CRLF & _
"////////////////////" & @CRLF & _
"Pay Charge" & @CRLF & _
"Mr Bump Smash Repair" & @CRLF & _
"Unit 12 122 Station Rd" & @CRLF & _
"Seven Hills NSW 2147" & @CRLF & _
"/////// suburb spelling error, character in street line" & @CRLF & _
"Woollahra Auto***cod***" & @CRLF & _
"120, Oxford St" & @CRLF & _
"Woolahra NSW 1350" & @CRLF & _
"/// name not complete" & @CRLF & _
"North Caringbah Smash Rep" & @CRLF & _
"47 Captain Cook Drive" & @CRLF & _
"Caringbah NSW 2229" & @CRLF & _
"/////" & @CRLF & _
"BM Pro Service Centre" & @CRLF & _
"Unit8/ 1a Pritchard Plac" & @CRLF & _
"Peakhurst NSW 2210 " & @CRLF & _
"////" & @CRLF & _
"embassy smash repairs" & @CRLF & _
"unit 5d 23-25 windsor rd" & @CRLF & _
"northmead nsw 2152"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")