// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\S| )+\n(\S| )+\n(\S| )+\n((\S| )+|)NSW \d{4}").unwrap();
let string = "/////// 4 lines & 3rd line is suburb only
SCIENTIFIC MOTOR BODYWORKS LP
7-9 PERRY STREET
MATRAVILLE
NSW 2036
///////
au
Mascot Auto Repairs\"cod**
155 Coward Street
Mascot NSW 2020
////////////////////////
Mascot Airport Service Station *cod*
Inside Car Wash
237 O'Riordan St
Mascot NSW 2020
////////////////////////maps
7/30-32 Beaconsfield Street
Alexandria NSW 2015
////////////////////////
Pedders Mascot
Unit 1
20 Ricketty Street
Mascot NSW 2020
/////////////////////
Pay Charge
Mr Bump Smash Repair
Unit 12/122 Station Rd
Seven Hills NSW 2147
////////////////////
Pay Charge
Mr Bump Smash Repair
Unit 12 122 Station Rd
Seven Hills NSW 2147
/////// suburb spelling error, character in street line
Woollahra Auto***cod***
120, Oxford St
Woolahra NSW 1350
/// name not complete
North Caringbah Smash Rep
47 Captain Cook Drive
Caringbah NSW 2229
/////
BM Pro Service Centre
Unit8/ 1a Pritchard Plac
Peakhurst NSW 2210
////
embassy smash repairs
unit 5d 23-25 windsor rd
northmead nsw 2152";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}