import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S| )+\\n(\\S| )+\\n(\\S| )+\\n((\\S| )+|)NSW \\d{4}";
final String string = "/////// 4 lines & 3rd line is suburb only\n"
+ "SCIENTIFIC MOTOR BODYWORKS LP\n"
+ "7-9 PERRY STREET\n"
+ "MATRAVILLE\n"
+ "NSW 2036\n"
+ "///////\n"
+ "au\n"
+ "Mascot Auto Repairs\"cod**\n"
+ "155 Coward Street\n"
+ "Mascot NSW 2020\n"
+ "////////////////////////\n"
+ "Mascot Airport Service Station *cod*\n"
+ "Inside Car Wash\n"
+ "237 O'Riordan St\n"
+ "Mascot NSW 2020\n"
+ "////////////////////////maps\n"
+ "7/30-32 Beaconsfield Street\n"
+ "Alexandria NSW 2015\n"
+ "////////////////////////\n"
+ "Pedders Mascot\n"
+ "Unit 1\n"
+ "20 Ricketty Street\n"
+ "Mascot NSW 2020\n"
+ "/////////////////////\n"
+ "Pay Charge\n"
+ "Mr Bump Smash Repair\n"
+ "Unit 12/122 Station Rd\n"
+ "Seven Hills NSW 2147\n"
+ "////////////////////\n"
+ "Pay Charge\n"
+ "Mr Bump Smash Repair\n"
+ "Unit 12 122 Station Rd\n"
+ "Seven Hills NSW 2147\n"
+ "/////// suburb spelling error, character in street line\n"
+ "Woollahra Auto***cod***\n"
+ "120, Oxford St\n"
+ "Woolahra NSW 1350\n"
+ "/// name not complete\n"
+ "North Caringbah Smash Rep\n"
+ "47 Captain Cook Drive\n"
+ "Caringbah NSW 2229\n"
+ "/////\n"
+ "BM Pro Service Centre\n"
+ "Unit8/ 1a Pritchard Plac\n"
+ "Peakhurst NSW 2210 \n"
+ "////\n"
+ "embassy smash repairs\n"
+ "unit 5d 23-25 windsor rd\n"
+ "northmead nsw 2152";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}