re = /^(\d+) (?:<(CARRE)> (\d+) (\d+) (\d+) (\d+) <\/CARRE>|<(RECTANGLE)> (\d+) (\d+) (\d+) (\d+) <\/RECTANGLE>|<(CERCLE)> (\d+) (\d+) (\d+) <\/CERCLE>|<(OVALE)> (\d+) (\d+) (\d+) (\d+) <\/OVALE>|<(LIGNE)> (\d+) (\d+) (\d+) (\d+) <\/LIGNE>)$/
str = '1111 <CARRE> 123 321 111 222 </CARRE>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end