const regex = new RegExp('^(\\d+) (?:<(CARRE)> (\\d+) (\\d+) (\\d+) (\\d+) </CARRE>|<(RECTANGLE)> (\\d+) (\\d+) (\\d+) (\\d+) </RECTANGLE>|<(CERCLE)> (\\d+) (\\d+) (\\d+) </CERCLE>|<(OVALE)> (\\d+) (\\d+) (\\d+) (\\d+) </OVALE>|<(LIGNE)> (\\d+) (\\d+) (\\d+) (\\d+) </LIGNE>)$', 'g')
const str = `1111 <CARRE> 123 321 111 222 </CARRE>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}