using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+) (?:<(CARRE)> (\d+) (\d+) (\d+) (\d+) </CARRE>|<(RECTANGLE)> (\d+) (\d+) (\d+) (\d+) </RECTANGLE>|<(CERCLE)> (\d+) (\d+) (\d+) </CERCLE>|<(OVALE)> (\d+) (\d+) (\d+) (\d+) </OVALE>|<(LIGNE)> (\d+) (\d+) (\d+) (\d+) </LIGNE>)$";
string input = @"1111 <CARRE> 123 321 111 222 </CARRE>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}