#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\d+) (?:<(CARRE)> (\d+) (\d+) (\d+) (\d+) </CARRE>|<(RECTANGLE)> (\d+) (\d+) (\d+) (\d+) </RECTANGLE>|<(CERCLE)> (\d+) (\d+) (\d+) </CERCLE>|<(OVALE)> (\d+) (\d+) (\d+) (\d+) </OVALE>|<(LIGNE)> (\d+) (\d+) (\d+) (\d+) </LIGNE>)$"
Local $sString = "1111 <CARRE> 123 321 111 222 </CARRE>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")