// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[a|b]{2}a[a|b]*b[a|b]{4}\b|\b[a|b]ba[a|b][a|b]{2}\b|\bb[a|b]{1}a[a|b]{2}\b").unwrap();
let string = "aaabaaaa abaaaa baaaa aabaaaa aaaaaaba";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}