import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[a|b]{2}a[a|b]*b[a|b]{4}\\b|\\b[a|b]ba[a|b][a|b]{2}\\b|\\bb[a|b]{1}a[a|b]{2}\\b";
final String string = "aaabaaaa abaaaa baaaa aabaaaa aaaaaaba";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}