package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[a|b]{2}a[a|b]*b[a|b]{4}\b|\b[a|b]ba[a|b][a|b]{2}\b|\bb[a|b]{1}a[a|b]{2}\b`)
var str = `aaabaaaa abaaaa baaaa aabaaaa aaaaaaba`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}