const regex = /\b[a|b]{2}a[a|b]*b[a|b]{4}\b|\b[a|b]ba[a|b][a|b]{2}\b|\bb[a|b]{1}a[a|b]{2}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a|b]{2}a[a|b]*b[a|b]{4}\\b|\\b[a|b]ba[a|b][a|b]{2}\\b|\\bb[a|b]{1}a[a|b]{2}\\b', 'g')
const str = `aaabaaaa abaaaa baaaa aabaaaa aaaaaaba`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}