re = /(?P<dup>(\w+\s+))(?P=dup)/m
str = '#命名表达式,并反向引用。比如查找重词
1 hello hello
2 hello world
3 妮妮好
4 你 你
5 wo wo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end