package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<dup>(\w+\s+))(?P=dup)`)
var str = `#命名表达式,并反向引用。比如查找重词
1 hello hello
2 hello world
3 妮妮好
4 你 你
5 wo wo
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}