import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<dup>(\\w+\\s+))(?P=dup)";
final String string = "#命名表达式,并反向引用。比如查找重词\n"
+ "1 hello hello \n"
+ "2 hello world\n"
+ "3 妮妮好\n"
+ "4 你 你 \n"
+ "5 wo wo \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}