using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<dup>(\w+\s+))(?P=dup)";
string input = @"#命名表达式,并反向引用。比如查找重词
1 hello hello
2 hello world
3 妮妮好
4 你 你
5 wo wo
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}