re = /(\w+)\(([^)]*)\)/m
str = '#5 0xfffffffff2fdc24f in cma__thread_base(tcb=0x8167060)
ALPHAFOLD(params.fasta) jimmy()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end