using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\(([^)]*)\)";
string input = @"#5 0xfffffffff2fdc24f in cma__thread_base(tcb=0x8167060)
ALPHAFOLD(params.fasta) jimmy()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}