package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\(([^)]*)\)`)
var str = `#5 0xfffffffff2fdc24f in cma__thread_base(tcb=0x8167060)
ALPHAFOLD(params.fasta) jimmy()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}