const regex = new RegExp('(\\w+)\\(([^)]*)\\)', 'gm')
const str = `#5 0xfffffffff2fdc24f in cma__thread_base(tcb=0x8167060)
ALPHAFOLD(params.fasta) jimmy()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}