re = /www\.hasbro\.com\/(.{1,10})\/\s?$/
str = 'https://www.hasbro.com/zh-hant-tw/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end