package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`www\.hasbro\.com\/(.{1,10})\/\s?$`)
var str = `https://www.hasbro.com/zh-hant-tw/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}