using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"www\.hasbro\.com\/(.{1,10})\/\s?$";
string input = @"https://www.hasbro.com/zh-hant-tw/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}