$re = '/www\.hasbro\.com\/(.{1,10})\/\s?$/';
$str = 'https://www.hasbro.com/zh-hant-tw/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);