// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([0-9]+)(\/)([0-9]+)(\/)([0-9][0-9]) ([0-9]+):([0-9][0-9]) (a|p).\s(m).").unwrap();
let string = "3/10/20 2:25 p. m. - rogertovalle: Buenas tardes
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}