re = /^([0-9]+)(\/)([0-9]+)(\/)([0-9][0-9]) ([0-9]+):([0-9][0-9]) (a|p).\s(m)./
str = '3/10/20 2:25 p. m. - rogertovalle: Buenas tardes
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end